SafeBase Trust Center Settings currently experiencing timeout issues

Incident Report for SafeBase

Resolved

A connection with third-party service that was interrupted due to scheduled maintenance.
This caused our settings page to become briefly unavailable.
The issue has been resolved, and new monitoring tasks have been added to prevent similar issues in the future.
Posted Mar 13, 2025 - 08:13 PDT

Update

We are continuing to investigate this issue.
Posted Mar 13, 2025 - 08:10 PDT

Investigating

We are currently investigating this issue.
Posted Mar 13, 2025 - 07:32 PDT
This incident affected: Main App.