GCP Global Outage

Incident Report for SafeBase

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 14:32 PDT

Update

We are beginning to see signs of resolution for the GCP outage that impacted the globe, and extremely impacted GCP's us-central1.

We are continuing to explore application behavior to determine whether the outage is fully mitigated.
Posted Jun 12, 2025 - 14:03 PDT

Update

We are continuing to monitor the GCP major outage and will provide additional updates when available.

Affected services still consist of:
- Downloading, viewing and uploading documents
- AIQA
- Analytics Dashboards (Explo)
- Trust Center Preview mode
- Questionnaire upload and download
- Custom icons, favicon
- Clickwrap NDA
Posted Jun 12, 2025 - 12:54 PDT

Update

Google Cloud Platform reports that the outage is nearing resolution.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 12:40 PDT

Monitoring

We are continuing to monitor the situation. Here is a summary of the impact of the outage:

Unaffected services:
- Visit Public Trust Center
- Knowledge Base Managment
- Documents Download
- Trust Center Editor
- Linking Documents
- Trust Center Updates
- Account members can view private content but cannot download content

Affected services:
- Downloading, viewing and uploading documents
- AIQA
- Analytics Dashboards (Explo)
- Preview mode is down
- Questionnaire upload and download
- Custom icons, favicon
- Account pages can be slow to load
- Clickwrap NDA
Posted Jun 12, 2025 - 12:26 PDT

Update

We are continuing to monitor the situation. Here is a summary of the impact of the outage:

Unaffected services:
- Visit Public Trust Center
- Knowledge Base Managment
- Documents Download
- Trust Center Editor
- Linking Documents
- Trust Center Updates
- Account members can view private content but cannot download content

Affected services:
- Downloading, viewing and uploading documents
- AIQA
- Analytics Dashboards (Explo)
- Preview mode is down
- Questionnaire upload and download
- Custom icons, favicon
- Account pages can be slow to load
- Clickwrap NDA
Posted Jun 12, 2025 - 12:24 PDT

Update

We are experiencing this issue due to the multi-regional GCP outage. Check their status page here:

https://status.cloud.google.com/
Posted Jun 12, 2025 - 12:09 PDT

Identified

We are currently investigating this issue.
Posted Jun 12, 2025 - 12:04 PDT
This incident affected: Core Infrastructure (Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Cloud Datastore), Third Party Integrations (Dashboards (Explo)), and SafeBase.