Email outage 08/14/2025

Incident Report for SafeBase

Resolved

The issue is resolved, all emails are being sent out as usual.
Posted Aug 14, 2025 - 09:34 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 14, 2025 - 09:33 PDT

Monitoring

The issue was resolved, we're monitoring to ensure all emails go out and the issue doesn't re-occur.
Posted Aug 14, 2025 - 09:28 PDT

Identified

An outage has caused an issue in sending emails resulting in all emails being stuck. We have found the issue and are working on a solution.
Posted Aug 14, 2025 - 09:14 PDT
This incident affected: SafeBase and Third Party Integrations (Postmark).