Emails not sending out
Incident Report for SafeBase
Resolved
This has been resolved.
Posted Jul 18, 2022 - 07:36 PDT
Update
We are continuing to investigate this issue.
Posted Jul 18, 2022 - 07:36 PDT
Investigating
We are currently investigating an issue with our email provider and emails not being sent out.
Posted Jul 18, 2022 - 07:11 PDT
This incident affected: Main App.