Questionnaire Experience Degradation

Incident Report for SafeBase

Resolved

This was a downstream GCP issue which has since been resolved.
Posted May 29, 2025 - 11:59 PDT

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 08:57 PDT
This incident affected: Google Cloud Platform Google Cloud Datastore.