Feature degradation - PDF File viewer issue
Incident Report for SafeBase
Resolved
The SafeBase team identified the problem and released a hotfix.
Posted Oct 11, 2024 - 09:06 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2024 - 07:58 PDT
This incident affected: Main App.