Emails delayed
Incident Report for SafeBase
Resolved
Postmark service issue seems to have been resolved and all emails in the queue have been delivered.
Posted Dec 17, 2022 - 05:58 PST
Identified
Postmark, SafeBase's email delivery provider, is having an outage at the moment. This is causing emails to be delayed. Once service is restored, all emails in the queue will be delivered.
Posted Dec 16, 2022 - 14:02 PST
This incident affected: Postmark.