Page is slowly response
Incident Report for SafeBase
Resolved
The DDoS attack has been stopped and we have added additional mitigations to reduce the risk of future DDoS attacks.
Posted Oct 12, 2023 - 09:51 PDT
Identified
We are experiencing a DDOS attack, we are handling it now.
Posted Oct 12, 2023 - 09:03 PDT
This incident affected: Main App.